Bad Request: Chef Client version between 10 and 11

Peter Burkholder -

ERROR: The data in your request was invalid
Response: {"error": "400 - Bad Request: Chef Client version between 10 and 11" required. Your version of Chef is 12.0.3.”}

Most likely this is a result of using chef-client version 12 with an 11.X Chef server.

The chef-client 12 is completely compatible with the 11.X Chef server. To enable the Chef server to accept the chef-client 12 requests, update private-chef.rb with:

lb['chef_max_version'] = 12

and run private-chef-ctl reconfigure.

Have more questions? Submit a request

Comments

Powered by Zendesk