Delivery chefdk-0.12.0 Berkshelf Issues

Sean Horn -

If you see an issue like this in all of your syntax, unit, and other phases, please uninstall chefdk-0.12.0 on all the builders and reinstall with chefdk-0.10.0. ChefDK may have been inadvertently upgraded on those builder nodes.

 

Berkshelf command failed�
�STDOUT: 
STDERR: /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/chef-config-12.7.2/lib/chef-config/workstation_config_loader.rb:159:in `rescue in read_config': You have an error in your config file /var/opt/delivery/workspace/.chef/knife.rb (ChefConfig::ConfigurationError)

Gem::ConflictError: Unable to activate chef-12.8.1, because chef-config-12.7.2 conflicts with chef-config (= 12.8.1)
  /var/opt/delivery/workspace/.chef/knife.rb:1:in `from_string'
Relevant file content:
  1: require 'chef/config'
  2: current_dir = File.dirname(__FILE__)
  3: ::Chef::Config.from_file("/etc/chef/client.rb")
  4: log_location STDOUT
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/chef-config-12.7.2/lib/chef-config/workstation_config_loader.rb:138:in `read_config'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/chef-config-12.7.2/lib/chef-config/workstation_config_loader.rb:73:in `load'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/ridley-4.5.0/lib/ridley/chef/config.rb:13:in `initialize'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf.rb:90:in `new'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf.rb:90:in `chef_config'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/config.rb:80:in `<class:Config>'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/config.rb:4:in `<module:Berkshelf>'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/config.rb:3:in `<top (required)>'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/cookbook_generator.rb:3:in `require_relative'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/cookbook_generator.rb:3:in `<class:CookbookGenerator>'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/cookbook_generator.rb:2:in `<module:Berkshelf>'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/cookbook_generator.rb:1:in `<top (required)>'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf.rb:197:in `require_relative'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf.rb:197:in `<top (required)>'
	from /opt/chefdk/embedded/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /opt/chefdk/embedded/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/lib/berkshelf/cli.rb:1:in `<top (required)>'
	from /opt/chefdk/embedded/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /opt/chefdk/embedded/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /opt/chefdk/embedded/lib/ruby/gems/2.1.0/gems/berkshelf-4.3.0/bin/berks:3:in `<top (required)>'
	from /opt/chefdk/bin/berks:48:in `load'
	from /opt/chefdk/bin/berks:48:in `<main>'
Have more questions? Submit a request

Comments

Powered by Zendesk